Fabric-Loader
红票19 (79%)黑票5 (21%)
模组属性评比
    57.69%的人认为Fabric...好玩。
    50%的人认为Fabric...太简单。
    65.38%的人认为Fabric...很稳定。
    65.38%的人认为Fabric...很实用。
    34.62%的人认为Fabric...很漂亮。
    73.08%的人认为Fabric...合理。
    53.85%的人认为Fabric...兼容好。
    65.38%的人认为Fabric...很耐玩。
路过的这位少侠,你觉得这款Mod怎么样,可否愿意来评一评它呢?登录并评比
更新日志更多
历史编辑记录更多
    管理组申请

      暂无管理组..

    开发组申请
    活跃
    开源

    Fabric-Loader

    • 支持平台: JAVA版 (JAVA Edition)
    • 运作方式: 文件覆盖
    • 运行环境: 客户端必装, 服务端必装
    • 收录时间: 2年前
    • 编辑次数: 69次
    • 最后编辑: 7天前
    • 最后推荐: 1月前
    • 模组标签:
    • 支持的MC版本:
    • Mod作者/开发团队:
      显示更多成员

    0.5

    闻所未闻

    昨日指数: 211
    昨日平均指数: 117.307

    27.66万

    总浏览

    --

    资料填充率


    下载本模组
    • Fabric 由 Fabric-loom , Fabric-Loader 和 Fabric-API (CurseForge)组成,其中 Fabric-Loader 是最基础的组件;在大多数情况下需要同时安装Loader和API,面对开发者还需要Fabric-loom。目前 Fabric-Loader 在官网支持 MultiMC、原版(Vanilla)、服务器(Server)、MCUpdater 和 Technic 的安装。对于开发者则需要去下载官方示例mod(GitHub) 还有去构建版本网站检索版本(modmuss50.me)。

      另在 Jenkins 上有 Fabric-installerFabric-Loader 的下载。


      Fabric 官方有较为完善的开发文档 Fabric Wiki(英文)。

      Fabric 官方有中国玩家上传的中文开发和使用文档Fabric Wiki(中文),但比较老旧。

      另在中文论坛上有玩家翻译的中文开发文档(Mcbbs)。


      关于 Fabric 更详细页面介绍和安装使用方法请查看 Fabric 官网


      致编辑者:模组使用的 API 在相应页面的运作方式中已有体现,请不要在本界面的模组中添加依赖 Fabric 的模组关系。


      Fabric 是一个用于 Minecraft 1.14.x 的轻量 Mod API,主要作者是 asiekierka(前 BuildCraft 维护人,Charsets 作者)和 modmuss50(TechReborn 和 Steve Carts Reborn 作者)。


      Fabric 提供一些基础的接口,允许其它模组注册物品、方块、模型、界面等,也提供一些事件。它也允许模组通过 SpongePowered Mixin 修改 Minecraft 字节码。与 Forge 的 coremod 系统相比,Mixin 可以更好地控制字节码改动,而且更安全。


      Fabric 对跨版本模组开发兼容性很强,在不写Mixin的情况下,可以进行更新而不改动模组内部太多的代码;使用Mixin的情况下也只需要进行略微的修改排错。正是因为这个,各位modder也逐渐开始接触fabric的制作。


      Fabric 模组并不是最重要的一部分。实现加载模组的部分是 Fabric Loader,Fabric 模组需要有 Fabric Loader 才能运行。Fabric 和 Fabric Loader 的关系有点类似 Minecraft Forge 和 Forge Mod Loader 的关系,只是 Fabric Loader 功能较少(专门读取 mod),更轻量。


      Fabric 并不采用 Mod Coder Pack。它有自己的反混淆工程,名叫 yarn(原名 pomf)。yarn 是开源的,任何人可以贡献,开源协议是 CC0 1.0 Universal。因为 Mod Coder Pack 协议限制,给 Fabric 的贡献的内容不能来源于 Mod Coder Pack。


      Fabric 在 2016 年左右,1.11 快照时期就出现了。然而后来 asiekierka 逐渐不活跃,Fabric 也销声匿迹。然而,在 2018 年 10 月左右(18w43c 左右),modmuss50 和 asiekierka 回归,Fabric 卷土重来。


      目前支持的最新正式版本是 Minecraft 1.16.5 。

      目前支持的最新快照版本是 Minecraft 21w16a。 果然你Fabric还是你Fabric

      它是少有的支持愚人节版本的 Mod API。(支持 3D Shareware 1.34 和 20w14∞ 版本)

      它也是少有的支持快照版本的 Mod API。Forge大失败毕竟Forge规模大没法跟Fabric比

      Fabric 采用自带的 Knot 启动,支持 Java 8 以及更新的 Java 版本。(目前Fabric API不支持Java 17,Fabric Loader本体可以在Java 17上成功启动)

      Fabric内带支持其他JVM编程语言的接口,所以让它支持其他JVM编程语言十分容易。看看KotLin For Forge和Fabric Language Kotlin的代码量就知道了

    短评加载中..