Scorge
模组属性评比

距离显示结果还剩5票~

路过的这位少侠,你觉得这款Mod怎么样,可否愿意来评一评它呢?登录并评比
更新日志
  • 暂无日志..

历史编辑记录更多
    管理组申请

      暂无管理组..

    编辑组申请

      暂无编辑组..

    开发组申请

      暂无开发组..

    最近参与编辑
    活跃
    开源

    Scorge

    • 支持平台: JAVA版 (JAVA Edition)
    • 运作方式: Forge
    • 运行环境: 客户端需装
    • 收录时间: 1月前
    • 支持的MC版本:
    • Mod作者/开发团队:
      显示更多成员

    0.0

    无人问津

    昨日指数: 5
    昨日平均指数: 153.741

    688

    总浏览

    --

    资料填充率


    暂无下载
    • Scorge

      一个 Forge 语言加载 Scala 编程语言的加载器。

      • 支持Scala版本

      当前支持版本为 2.13.4。

      • Shaded libraries

      Scorge目前包括scala-library与scala-java8-compat。

      • Scala Version Policy

      Scorge 将只支持 Scala 的最新主要版本, 一旦Forge有稳定的版本后,它将锁定Scala版本,直到其下一个稳定的版本。Scorge不会支持发布候选或Scala的里程碑版本。

      • Scorge library policy

      如果您想添加一个新的库,以支持Scorge。

      1. 它必须是用Scala制作。你必须要有很好的技术,这也是为什么Scala它会更好地支持在Scorge,而不是简单地添加到您的模组。

      2. 如果您想删除由Scorge支持的库,必须在 Minecraft 的版本切换期间完成,才能在后面的MC版本中不去破坏它的兼容性。这也是你得有一个很好的技术原因之一。


      用法

      按照前项目添加 Scorge 作为 maven 依赖性,并将其放置在运行目录中的模组文件夹中,或手动将其添加到类路径中。这是由于语言提供商是按 fml 加载的特殊方式, 对此无能为力。

    短评加载中..