• >
  • LIBMod
  • >
  • 版本兼容 (CompatLayer)
版本兼容 (CompatLayer)
红票17 (89%)黑票2 (11%)
模组属性评比

距离显示结果还剩4票~

路过的这位少侠,你觉得这款Mod怎么样,可否愿意来评一评它呢?登录并评比
更新日志
  • 暂无日志..

历史编辑记录更多
    管理组申请

      暂无管理组..

    编辑组申请

      暂无编辑组..

    开发组申请

      暂无开发组..

    活跃

    版本兼容

    CompatLayer

    • 作者/开发团队: Mcjty
    • 收录时间: 3年前
    • 编辑次数: 6次
    • 最后编辑: 11月前
    • 最后推荐: 1月前
    • 支持的MC版本:

    0.0

    无人问津

    昨日指数: 46
    昨日平均指数: 164.838

    10.15万

    总浏览

    --

    资料填充率


    下载本模组
    • 是一些模组的前置。

      这个小模组可以让你写的mod同时兼容1.10和1.11。如果你正确的使用此modAPI,可以让你不用开发两个版本。

       

      除了这个库所做的一些事情你应该做些什么:

       

      • 将所有在1.10.2创建的资源名称,如(lang,模型,贴图,代码等)变成小写。并添加一个FMLMissingMapping事件来保持旧世界的正确加载

      • Mod id 也要小写

      • 把tileEntity.worldObj 方法替换为tileEntity.getWorld()方法

      • 把entityPlayer.worldObj方法替换为entityPlayer.getEntityWorld()方法

      这是一个Alpha版本。可能并不全部兼容or还有问题

      相关链接如下

      Wiki: https://github.com/McJty/compatlayer/wiki

      Modder需要用到的教程: https://modwiki.temporal-reality.com/mw/index.php?title=CompatLayer-1.11

      1.10.2的Jenkins地址: https://jenkins.k-4u.nl/view/McJty/job/Compatlayer%201.10/

      1.11的Jenkins地址: https://jenkins.k-4u.nl/view/McJty/job/Compatlayer%201.11/


    短评加载中..